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1. Informatikwerkstatt

Lernziele, Inhalt, Bewertung

Lernziele:
m Kennenlernen typische Arbeitsfelder und berufsbezogene
Tatigkeiten,
m Grundfertigkeiten fiir die Software-Entwicklung:
= Analyse von Problemstellungen,
= Implementierung, Test, Fehlersuche,
m Team-Arbeit, Prédsentation der Lésungen, ...
Inhalt:
m EinfUhrung in ein bis zwei Programmiersprachen und
Programmierumgebungen,
m interaktive Rechneriibungen und Mini-Projekte,
m Abschlussprojekt und Projektprasentation.
Bewertung:
m unbenoteter Leistungsnachweis
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2. Informatikwerkstatt-MR

Lern- und Arbeitsziel

m Schrittweise Heranflihrung an die Entwicklung / Inbetriebnahme /
Fehlersuche programmierter MR.

m Konfiguration eines Fahrzeugs mit einer Mikrorechnerbaugruppe
und Ansteck- (PMod-) Modulen®.

IBenachbarte Arbeitsplétze bilden eine 2er- bzw. 3er-Gruppe mit je einem Satz
Hardware.
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2. Informatikwerkstatt-MR

Abschlussprojekt

Demonstrator fir ein autonomes Fahrzeug, programmiert nach einer
selbst gewahlten mit dem Betreuer abgesprochenen Spezifikation oder
ein andere MR-Projekt.

Kann ich das?
m Kein Hexenwerk. Interesse wichtiger als Vorkenntnisse. J
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2. Informatikwerkstatt-MR

Zeitablauf, Leistungsnachweis

m erste Semesterhélfte: Mo. 15:30 bis 17:00 und Di. 17:15 bis 18:00
BBB-Vorlesung, anschlieBend bis 19:00 Ubung

= ca. ab Mitte Dezember bis vorletzte VL-Woche nur Ubung

m letzte Vorlesungswoche: Prasentation der Abschlussprojekte.

= Zu den Ubungen ist corona-bedingt je Zweiergruppe alternierend
nur eine Person vor Ort und die zweite Gber BBB verbunden.

Zu erbringende Leistungen:

m Vorfliihrung geldster Aufgaben. Schwierigkeit nach Vorkenntnissen
in Absprache mit Betreuer.

m Abschlusspréasentation.

= Arbeitsumfang incl. Vorlesungsstunden 6 LP2.

Bei Abwesenheit sind die zu erbringenden Leistungen nachzuholen.

21LP=30h,6LP = 180h, 14 Vorlesungswochen, ca. 13 Arbeitsstunden, 6 Prasenzzeit
+ 7 Eigenstudium pro Vorlesungswoche.
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2. Informatikwerkstatt-MR

Arbeitsprogramm

m Kennenlernen der Entwickungsumgebung (Atmel-Studio, ...).

m Bitverarbeitung: Einfache Programme mit Eingabe lber Schalter
und Ausgabe an LEDs, Automaten, ...

m C-Programmierung, Datentypen, Modularisierung, Modultest, ...

m PC als Ein- und Ausgabe. Logikanalyse. Python fir Programmtest
vom PC aus. ...

m Ansteuerung weiterer Hardware-Einheiten (Ultraschallsensor,
LC-Display, Timer, ...).

= Nebenlaufigkeit: Treiber, Polling, Interrupts, Uberwachung von
Zeitablaufen.

m Motorsteuerung: Kennlinienbestimmung, Regelung, ...

Zu jedem Thema werden zu Beginn funktionierende
Programmbeispiele besprochen und gemeinsam getestet.
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3. MR-Programmierung
Das Versuchsboard

Schaltermodul

Kabel vom

Stecker- £ anzustecken fur

netzteil die ersten
Versuche

Programmier-
kabel
ya

=

"Einschal-
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3. MR-Programmierung

Schaltermodul
anzustecken fir
die ersten
Versuche

Inbetriebnahme Kabel vom
der Baugruppe

netzteil
Programmier-

m Programmieradapter
anstecken.

m Netzteil anstecken
(Achtung, nur 5 V-
Netzteile verwenden).

= Schaltermodul JA Stecker fir
(Port A3) anstecken weitere Ansteckmodule

m Erst wenn Hardware fertig zusammengesteckt, einschalten.

30ben angesteckt: SW1=JA.0, SW2=JA.1, SW3=JA.2, SW4=-JA 3. Unten angesteckt:
SW1=JA4, SW2=JA.5, SW3=JA.6, SWA=JA.7.
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3. MR-Programmierung
Verbindung mit dem Arbeitsplatzrechner @

D

m Rechner unter Windows starten
m Web-Browser (Firefox) 6ffnen. Foliensatz zum Mitlesen 6ffnen:
techwww.in.tu-clausthal.de/site/Lehre
/Informatikwerkstatt/
= Atmel Studio starten EJ.
m Zur Kontrolle, dass der Prozessor richtig angeschlossen und vom
System erkannt wird, in Atmel Studio
Tools > Device Programming
auswahlen. Nachfolgende Kontrollen vornehmen:

Tool Device Interface Device signature Target Voltage
IAUR Dragon  ATmega2560 IJTAG 'l Apphy IDx lEiaol I 3,2V  Read
Auswahlen Auswéhlen  Auswéhlen Kontrolle Kontrolle
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4. Das erste Programm

Das erste Programm Port A (Schalter) Eingang
Port J (LEDs) Ausgang

Wiederhole immer
#include <avr/io.h> lese Byte von Port A

int main(O{ schreibe Byte auf Port J

DDRA = 0bOOOOOOOO; // Port A (Schalter) Eingdnge
DDRJ = Ob11111111; // Port J (LEDs) Ausginge

uint8_t a; // Variable, 8-Bit positiv

while (1) { // Endlosschleife
a = PINA; // Lesen der Schalterwerte
PORT] = a; // Ausgabe auf die LED

}

}

m Programmierprojekt anlegen.

m Programm eingeben und Ubersetzen.

m Programm laden. (Hardware zusammenstecken.)

m Programm testen.
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4. Das erste Programm

Projekt einrichten

m Neues Projekt anlegen:

File > New > Project > GCC C Executable
Project Name: »bit_io1«. Location: C:\Informatikwerkstatt.
Prozessortyp: Atmega2560.

m Programmier-Tool / Schnittstelle auswahlen:

G. Kemnitz -

Project > bit_iol Properties (Alt + F7) >

Tool > AVR Dragon ..., JTAG

£ Configuration: IF-J;"A ‘l Platform: IN;‘A 'I

Buid Events
Toolchain Selected debugger/programmer
Device | AVR Dragon - 004200025760 ¥ |  Interface: IJTAG -
Tool JTAG Clock
|
Advanced ’7 | | I—I,OOMHZ
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4. Das erste Programm

m Unter Toolchain die Optimierung fiir den Ubersetzer ausschalten:*
(»-O1« durch »-O0« ersetzen)

Build = f—ﬂ AVR/GNU Common AVR/GNU C Compiler = Optimization |
) ¥ General

Buid Events % OutputFiles Optimization Level: INone (-00) 'I
Toolchain* | = [Z] AVR/GNU C Compiler

“# General Other optimization flags: I
Device -

é g;irp]lngsssor IV Prepare functions for garbage collection
L “# Directories Iv Prepare data for garbage collection
Advanced 4 Optimization IV Pack Structure members together

m Zeilennummern einschalten:
Tools > Options > Text Editor > All languages

> Line numbers./
m Einstellungen Speichern (Strg + S).
4Optirniert sonst fiir das Ein-/Ausgabeverhalten entbehrliche Schritte weg, z.B. das
Zwischenspeichern von Variablenwerten im Datenspeicher und Warteschleifen.
Optimierte Programme lassen sich nur eingeschrénkt im Schrittbetrieb auf
Quellcodeniveau testen.
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4. Das erste Programm

I’rcqgralrtnn_eirq;el)erl

= Automatisch erzeugten Programmrahmen vervollstandigen®.

#include <avr/io.h>
int main(){
DDRA = 0bOOOOOOOO;
DDR] = Obl11111111;
uint8_t a;
while (1) {
a = PINA;
PORT] = a;
}
} m Speichern.

m Debugger starten: 2

//
//
//
//
//
//

Port A (Schalter) Eingdnge
Port J (LEDs) Ausgédnge
Variable, 8-Bit positiv
Endlosschleife

Lesen der Schalterwerte
Ausgabe auf die LED

Debug > Start Debugging and Break (Alt+F5).

5Das Beispielprogramm befindet sich mit im zip-File auf der Webseite.
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4. Das erste Programm

Debugger-Ansicht

(>t 2 Tlhx B
bit_iol.c + X
18 #include <avr/io.h>
£ 11 =int main(){
12 // Initialisierung
13 DDRA = @beeeeeeee; // Port A (Schalter) Einginge
14 DDRJ = 8b11111111; // Port 1 (LEDs) Ausginge

15 uint8_t a; J/ 8-Bit-Variable
16 while(1) { // Endlosschleife

@| 17 a = PINA; [/ Lese Schalterwert wvon Port A
18 PORT] = a; // Busgabe auf die LEDs an Port J
19 }
20 |}

Nachste auszuflihrende Anweisung.
Unterbrechungspunkt (Mouse-Click grauer Rand davor).

Schritt abarbeiten und halten.
Fortsetzen bis zum néchsten Unterbrechungspunkt.

v @
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4. Das erste Programm

Beobachtungsfenster 6ffnen @
Debug > Windows > IO
B 11AG
Ii9 PORTB
Name |Asddr| Value | Bits

10 PINA 20 oxo3 O0OO000C0D®
wpbrRa o0x21  oxoo 00000000
wprorRTA x22  o0x00 00000000

Debug > Windows > Watch > Watchl
16 while(1) {

17 a = PINA; |pnName | value Type

2 18 PORTI = a;| @ 3 3 uint8_t{data}@0x21fa ([R28]+1)
19| 3
20 | }
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4. Das erste Programm

Programm Testen

.

Schrittbetrieb:
m Schritt abarbeiten und halten (%').
m Werte in »|O« und »Watch 1« kontrollieren.

Test mit Unterbrechungspunkt:
= Unterbrechungspunkt ® setzen®.

m Start/Programmfortsetzung mit #.
m Werte in »10« und »Watch 1« kontrollieren.
m Schaltereingabe andern.

Test ohne Unterbrechung:
= Unterbrechungspunkt ® I6schen.
m Start/Programmfortsetzung mit #..
m Schaltereingabe andern und LED-Ausgabe kontrollieren.

®Mouse-Click auf den grauen Rand vor der Anweisung
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Python
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5. Python
Python ‘i‘

Mikrorechner haben weder Tastatur, noch Bildschirme, noch ein
Dateisystem, ... Bedienung und Test genau wie Programmierung Uber
eine serielle Verbindung vom PC aus. Python ist eine gute
Programmiersprache fir die Entwicklung von Demonstratoren und
Testrahmen:

m viel weniger Anweisungen als C fir dieselbe Funktion
m viel einfacher zu testen, ...
Python hier im Kurs:
m Steuerung und Test der Fahrzeuge.
m Graphische Darstellung der Sensor- und Bewegungsdaten.
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5. Python

Ausprobieren von Pr ogrammanweisungen

Python eignet sich u.a. deshalb gut zum Programmierenlernen und fur
Test-Scripte, weil sich Programmzeilen einzeln auf der Konsole testen
lassen. Start der Programmierkonsole »ldle« von EJ

> Start > Python 3.5 > IDLE (Python 3.5 ...)
Ausgabefunktion:

print (<0bj>{,0bj})
Ausprobieren von Anweisungen:

>> s = ’‘Hallo”’

>> print(3, 5==7, s) #Zahl, Wahrheitswert, Text
>> 3 False Hallo

>> print(type(s), len(s))

>> <type ’str’> 5
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5. Python

Textverarbeitung

Beim Testen sind gut lesbare Textdarstellungen wichtig. :
m unformatierte Textkonvertierung: str(<OB;>)
m formatierte Textkonvertierung: ’<Formatstring>’%(< Wertetupel)
m Verketten von Texten: Text1 + Text 2
Zum Ausprobieren auf der Konsole:
>> a=5; b=37.7; s="Hallo’
>> >print(str(a) + str(b) + s) #print(a, b, s)
>> 537.7Hallo
>> print (’a=%2i , . b=%4.2f: %s %(a,b,s))
>> a= 5, b=37.70: Hallo

("%s" — Text (string); "%ni" — ganze Zahl (int), Darstellung mit
mindestens n Zeichen; "%n.mf" — Gleitkommazahl (float), Darstellung
mit mindestens n Zeichen und m Nachkommastellen).
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5. Python

Sequenzobjekte: Zeichenkette, Tupel

Zeichenkette: Sequenz von Zeichen bzw. Bytes. Auswahl von
Elementen und Teilzeichenketten.

>> s="Hallo,Welt!”’
>> print(’s[3]="%s",.s[4:9]="%s" "%(s[3],s[4:91))
>> s[3]="1", s[4:9]="o_Wel'

Tupel: Sequenz beliebiger Objekte.

>> t = (“abc’, 3, 4.2)
>> print(t, t[1], t[1:2])
>> ((’abc’, 3, 4.2), 3, (3,))

Iteratoren: Funktionen zur Generierung allg. beschreibbarer Folgen.

>> print(range(5))

# Erzeugt Folge: 0, 1, 2, 3, 4

>> print(range(-4,2,1))

# Erzeugt Folge: -4, -3, -2, -1, 0, 1
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5. Python
Wiederholschleifen

Wiederholschleifen iterieren Uber Sequenzobjekte (Zeichenketten,
Tupel, Listen):

>> s="Hallo’
>> for c in s: # fiur alle Zeichen in s
print(c) # Einriucktiefe erhohen
# Einriucktiefe zuricksetzen

O K+ -

Auch hier nach »:« (fir den Schleifenkdrper) Einrticktiefe erhéhen und
nach der Schleife zuriicksetzen.
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5. Python

Zusatzliche Fallunterscheidung im Schleifenkérper:

>> 1=0;
>> for c in s:
if ¢c=="1": # Einriicktiefe erhohen
print(i) # Einriucktiefe erhohen
i=i+1 # Einrucktiefe zuricksetzen
. # Einriucktiefe zuricksetzen
2
3

Programme besser als Dateien eingeben und Testen. In der »Idle«:
File > New File (Ctrl+N)
Programmeingabe:
s="Hallo’; i=0;
for ¢ in s:
if c=’'1": # Einrucktiefe erhohen
print(i) # Einriucktiefe erhohen
i=i+1; # Einrucktiefe zurtcksetzen
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5. Python

Programm Speichern

File > Save (Ctrl+S), C:\Informatikwerkstatt\test.py
und starten
Run > Run Modul (F5).
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5. Python

Anwendungssysteme oder Mikrorechner?

m Anwendungssysteme / Python:

m Python bietet ein schlankes System von Funktionsbausteinen, die
zum Teil sehr komplex sind (Wérterblcher, Netzwerkkommunikation,
Threads, graphische 10, ...).

m Wenige Zeilen Python-Code ersetzen mehrere Seiten C-Code. Preis
wesentlich schnellere und leistungsféhigere Rechner.

m Schneller Prototyp-Entwurf, Testskripte, Skripte zum Trainieren von
neuronalen Netzen auf Servern, ...

m Informatikausbildung: Ubungen High-Level-Konzepte, ...

m Mikrorechner / C:

m Programmierung fast so, wie der Prozessor arbeitet.

m Hilfreich fur Versténdnis der Funktionsweise von Rechnern und der
internen Programmabarbeitung.

m Hardware-nahe Programmierung, Entwicklung von Gerétetreibern,
Betriebssystemen und Steuersystemen (z.B. fiir Maschinen und
Fahrzeuge).

m Vorbereitung auf praktische Arbeiten in der Technischen Informatik.

m Wer gut programmiert, braucht keine 32-Bit MCU.
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